Get it on Google Play تحميل تطبيق نبأ للآندرويد مجانا اقرأ على الموقع الرسمي

كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN

حضرموت التقنية

كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN

كان لدينا أحد متطلبات العملاء الأخيرة ل guest Wlan اي زوار الشبكة اللاسلكية مع وظيفة Hotspot لذلك فكرت لماذا لا نشارك هذي الاعدادات مع الجميع.

في مختبري التجريبي المتواضع ، أستخدم Mikrotik RB1200 كراوتر أساسي وموفر Hotspot و Mikrotik RBcAP2n باعتباره Wlan AP ولكن يمكنك استخدام أي تركيبة طالما تم توفير الوظيفة المطلوبة.

كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN

سوف أفترض أن لديك الان بعض المعارف الأساسية حول أجهزة ميكروتيك والشبكات ، لذا لن أخوض في تفاصيل إضافية حول تلك الأجزاء.

أولا وقبل كل شيء يجب توصيل كل شيء. أستخدم ether1 كمنفذ WAN الخاص بي. ether2 to 10 هي منافذ LAN (RB1200 بها 10 منافذ إيثرنت فقط).
قم بتوصيل جهاز راوتر الإنترنت الخاص بك بـ ether1 والكمبيوتر الخاص بك إلى جهاز ether 10.

وصّل جهاز Wireless الخاص بـ Mikrotik Wireless بأحد المنافذ الأخرى في حالتي التي يطلق عليها RBcAP2n أيضاً “Ufo”.

اتصل الآن بالراوتر الأساسي وقم بحذف التكوين ضمن System – > Reset Configuration (إذا كان لديك تكوين قد تحتاج إليه ، فيرجى إجراء نسخة احتياطية أولاً).

بمجرد إعادة ضبط التهيئة ، قم بالاتصال بالراوتر مرة أخرى باستخدام عنوان MAC وحذف التكوين الأولي وإعادة الاتصال.

يجب أن يكون لديك جهاز راوتر فارغ الآن.
جميع الخيارات متاحة من خلال واجهة المستخدم الرسومية ولكننا سنستخدم الترمينال Terminal.

تكوين ميكروتيك :

1) فتح محطة وتعيين هوية الجهاز:

/system identity set name=Baserouter

2) إنشاء البريدج :

/interface bridge
add mtu=1500 name=TestNetwork protocol-mode=none

اتصلت بشخصيتي “TestNetwork” ولكن يمكنك تسميتها كما تشاء.

3) أود أن أعلق على واجهات interfaces لذلك استخدم التعليق comment على ether1 و ether2

/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment="LAN 2-10"

4) الخطوة التالية هي إنشاء vlan interface إضافة معرف ID، وإرفاق واجهة bridge

/interface vlan
add interface=TestNetwork name=VLAN999 use-service-tag=yes vlan-id=999

اسم vlan interface في الاختبار الخاص بي هو “VLAN999” مع معرف “999”

5) لديك خيار إما تبديل أو توصيل المنافذ معا. يستخدم تجسير المنافذ برنامجًا لربط المنافذ مع بعضها ، ويسمح لك بالتحكم بشكل أفضل في الواجهات ، على سبيل المثال إعداد جدار الحماية فيما بينها.

الجانب السلبي الرئيسي هو أنه يستهلك موارد وحدة المعالجة المركزية CPU .

Switching يستخدم رقاقة التبديل لذلك لا تستهلك بالإضافة إلى وحدة المعالجة المركزية. ينصح هذا بشكل خاص على أجهزة Mikrotik منخفضة الميزانية.

5.a) للتوصيل ، قم بإضافة منافذ 2 -10 إلى البريدج (يمكنك اختيار عدد المنافذ التي ستتم إضافتها استنادًا إلى جهازك وتفضيلاتك) :

/interface bridge port
add bridge=eMINetwork interface=ether2
add bridge=eMINetwork interface=ether3
add bridge=eMINetwork interface=ether4
add bridge=eMINetwork interface=ether5
add bridge=eMINetwork interface=ether6
add bridge=eMINetwork interface=ether7
add bridge=eMINetwork interface=ether8
add bridge=eMINetwork interface=ether9
add bridge=eMINetwork interface=ether9

5. ب) لتبديل المنافذ معا:

/interface ethernet
set ether3 master-port=ether2
set ether4 master-port=ether2
set ether5 master-port=ether2
set ether6 master-port=ether2
set ether7 master-port=ether2
set ether8 master-port=ether2
set ether9 master-port=ether2
set ether10 master-port=ether2

ولا تنس إضافة منفذ LAN واحد على الأقل إلى VLAN bridge حتى يكون هناك اتصال بين شبكة VLAN والشبكة المحلية.

في حالتي سوف أقوم بإضافة واجهة ether2.

/interface bridge port
add bridge=TestNetwork interface=ether2

6) الآن يتيح إنشاء DHCP Client على منفذ WAN (على افتراض أن لدينا خادم DHCP على جهاز توجيه الإنترنت) وهو في حالتي ether1

/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=ether1

7) تعيين عناوين IP ثابتة إلى واجهة Bridge و VLAN. سأستخدم الشبكات 10.10.10.0/24 للشبكة المحلية و 172.27.71.0/24 للضيوف guests.

/ip address
add address=10.10.10.5/24 interface=TestNetwork network=10.10.10.0
add address=172.27.71.5/24 interface=VLAN999 network=172.27.71.0

8) الآن يتيح إنشاء hotspot profile مع IP ثابت واجهة VLAN واسم نظام أسماء النطاقات (I use login.hotspot.com ولكن يمكنك اختيار ما تريد).

/ip hotspot profile
add dns-name=login.hotspot.com hotspot-address=172.27.71.5 name=hsprof1

9) إنشاء اثنين من DHCP Pools ل LAN وضيوف مع 79 عناوين قابلة للاستخدام (مرة أخرى اختيار أي نطاق تحتاج ، أود أن احجز  أول 20 عنوان للطابعات والخوادم وأجهزة الشبكة الأخرى وهكذا).

/ip pool
add name=lan ranges=10.10.10.21-10.10.10.100
add name=guests ranges=172.27.71.21-172.27.71.100

10) إنشاء اثنين من DHCP Servers لـ IP Pools لدينا. لقد اخترت عقد إيجار lease  لمدة يوم واحد لمستخدمي الشبكة المحلية وتأجير ساعة واحدة للضيوف.

/ip dhcp-server
add address-pool=lan disabled=no interface=TestNetwork lease-time=1d \
name=dhcp1
add address-pool=guests disabled=no interface=VLAN999 lease-time=1h name=\
dhcp2

11) وأخيرا إنشاء خادم هوت سبوت وربطه إلى vlan interface

/ip hotspot
add address-pool=guests disabled=no interface=VLAN999 name=guesthotspot \
profile=hsprof1

12) الآن يتيح إنشاء user profile للضيوف مع اتصالات غير محدودة المتزامنة ، مهلة الخمول idle timeout لمدة 30 دقيقة ، والحفاظ على مهلة 2 ساعة keep alive-timeout ، والحد من معدل الحد rate limit من حوالي 10 ميغابت إلى أسفل ، 2.5 ميغابت حتى.

/ip hotspot user profile
add address-pool=guests idle-timeout=30m keepalive-timeout=2h name=guestprofile \
rate-limit=2500K/10000K shared-users=unlimited transparent-proxy=yes

13) إنشاء أول مستخدم ضيف باستخدام كلمة المرور “internet” وإرفاق ملف تعريف الضيف guest profile

/ip hotspot user
add name=guest password=internet profile=guestprofile

14) إنشاء قاعدة DNS: (OpenDNS و Google)

/ip dns
set allow-remote-requests=yes servers=208.67.222.222,8.8.8.8

15) إنشاء شبكة خادم DHCP

/ip dhcp-server network
add address=172.27.71.0/24 comment="guest network" gateway=172.27.71.5
add address=10.10.10.0/24 comment="lan" dns-server=192.168.71.5,8.8.8.8 gateway=\
10.10.10.5

16) إنشاء masquerade rule للجدار الناري للشبكة المحلية والشبكة المحلية لتأسيس اتصال إنترنت من wan

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
src-address=172.27.71.0/24

لقد انتهينا الآن من تكوين القاعدة على جهاز التوجيه الرئيسي. تكوّن مزيدًا من إمكانيات التهيئة بلا حدود وتسمح على سبيل المثال بتكوين قوائم الانتظار Queues، والحد من النطاق الترددي limit Bandwidth ، وما إلى ذلك ، لكنني لن أذهب إلى هذه التفاصيل للحفاظ على المقالة حول الموضوع.

تكوين Mikrotik WLAN AP

1) قم بالاتصال Access Point ميكروتيك وفرغ التكوين على الموجه الرئيسي

2) الآن يتم إنشاء 2 بريدج، واحدة لشبكة محلية عادية وواحد لضيوفنا guests

/interface bridge
add name=Bridge_LAN
add name=Bridge_Guests

3) إنشاء vlan interface وتعيينه إلى LAN Bridge

/interface vlan
add interface=Bridge_LAN loop-protect-disable-time=0s \
loop-protect-send-interval=0s name=Guest_VLAN use-service-tag=yes \
vlan-id=999

4) إنشاء Wireless security profiles لمستخدمي الشبكة المحلية والضيوف.

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
management-protection=allowed mode=dynamic-keys name=LANwifi \
supplicant-identity="" wpa-pre-shared-key=eMatrixreloaded \
wpa2-pre-shared-key=internetkey
add eap-methods="" management-protection=allowed name=guests \
supplicant-identity=""

5) إنشاء واجهات LAN و Guest WLAN مع SSIDs وإرفاق ملفات تعريف الأمان الخاصة بهم.

يمكنك تعديل النطاق والإعدادات الأخرى لاحقًا.

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no mode=ap-bridge \
radio-name=MikrotikAP security-profile=LANwifi ssid=MyWifi \
wireless-protocol=802.11
add disabled=no keepalive-frames=disabled \
master-interface=wlan1 mode=ap-bridge multicast-buffering=disabled name=\
wlan2 security-profile=guests ssid=Guest-Wifi wds-cost-range=0 \
wds-default-cost=0 wps-mode=disabled

6) مواصلة إضافة “ether1” و “wlan1” لبريدج “Bridge_LAN” و “Guest_VLAN” و “wlan2” لبريدج “Bridge_Guests”.

/interface bridge port
add bridge=Bridge_LAN interface=ether1
add bridge=Bridge_LAN interface=wlan1
add bridge=Bridge_Guests interface=Guest_VLAN
add bridge=Bridge_Guests interface=wlan2

7) تعيين عنوان IP لـ LAN Bridge

/ip address
add address=10.10.10.6/24 interface=Bridge_LAN network=10.10.10.0

8) إنشاء DHCP Client على vlan bridge لاختبار ما إذا كنت تحصل على gusts IP

/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=Bridge_Guests

9) وأخيراً إضافة route لشبكة الضيوف من خلال guests bridge

/ip route
add distance=1 dst-address=172.27.71.0/24 gateway=Bridge_Guests

سيكون هذا هو التكوين الأساسي لإنشاء نقطة اتصال مجانية للضيوف ونقلها عبر شبكة محلية ظاهرية إلى نقاط الوصول الخاصة بك.

اتصل بالشبكة المحلية اللاسلكية (WLAN) وتحقق من ما إذا تمت إعادة توجيهك إلى صفحة تسجيل الدخول الخاصة بك.

إذا لم تنجح في فتح نموذج موقع إلكتروني ، فيجب أن تبدأ عملية إعادة التوجيه الآن.

يرجى أن تضع في اعتبارك أن التكوين أعلاه بعيد عن قابلية الاستخدام للإنتاج.

لديك لتكوين كلمة مرور على الأقل لمستخدمك المشرف Mikrotik ، إنشاء قاعدة جدار الحماية الأساسية لحظر حركة المرور غير المرغوب فيها وهكذا.

أنتهى … كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN

كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN

ملاحظة :

قد تكون المقالة محمية ضد النقل وبالتالي لنسخ الاكواد ان وجدت انقر على علامة + بأعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

The post كيفية إنشاء نقطة Hotspot لـ Wlan وguest Wlan مع ميكروتيك باستخدام VLAN appeared first on حضرموت التقنية.

December 11th 2018, 4:41 am
اقرأ على الموقع الرسمي

0 comments
Write a comment
Get it on Google Play تحميل تطبيق نبأ للآندرويد مجانا