Get it on Google Play تحميل تطبيق نبأ للآندرويد مجانا اقرأ على الموقع الرسمي

إدارة عرض النطاق الترددي الكامل بقائمة Queue Tree في سيرفر المايكروتك

حضرموت التقنية

إدارة عرض النطاق الترددي الكامل بقائمة Queue Tree في سيرفر المايكروتك

هذا هو الجمع بين أساليب إدارة النطاق الترددي واستكمالها مسبقًا باستخدام قائمة Queue Tree وبالتالي التعامل مع جميع أنواع الأغراض في شبكة الإنترنت الأكثر تعقيدًا.

يمكنك ببساطة تطبيق قائمة Queue Tree البسيطة للحد من عرض النطاق الترددي بحيث تكون قوية وحازمة لكل عميل على شبكة الإنترنت الخاصة بك.

تكمن المشكلة في أننا إذا قمنا بمشاركة عرض النطاق الترددي مع قائمة Queue Tree بسيطة وصلبه

فمن الصعب بالنسبة لي أن أقوم بالتقسيم إلى العديد من العملاء بشكل طبيعي.

لهذا سيكون من المناسب أن نطبقها على هذا النوع من اتصال الإنترنت المخصص.

لاحظ الفيديو قد تحتاجة :

على سبيل المثال ، إذا كان لديّ اتصال إنترنت للنطاق الترددي بالكامل يصل إلى 2M ، بعد أن اختبرته عن طريق اختبار السرعة ، يبلغ متوسط عرض النطاق الترددي 512 كيلو بايت في الثانية.

وهذا يعني أنه إذا كان لدي 6 عملاء ، يكون 512/6 = 86 كيلو بايت في الثانية / عملاء بشكل طبيعي ، فإن الرقم المثالي صغير جدًا وهو غير مناسب لعملائنا.

إذا كان عرض النطاق الترددي الذي يصل إلى 2 ميقا محسوبًا في الفترة 2000/6 حوالي 334 كيلو بت في الثانية / عملاء ، فيمكنه أن يجعل التصفح واللعب عبر الإنترنت عالقين إذا كان هناك عميل واحد فقط قام بتنزيل وتشغيل مقاطع الفيديو ، لأن العميل يقضي تقريباً على كل المتوسط للسرعة (512 كيلو بايت في الثانية) سيكون العملاء الآخرون في مشكلة خاصة فقط للتصفح أو اللعب عبر الإنترنت. في هذه الحالة نحتاج إلى الأولوية للحزم الرابعة.

تكمل إدارة النطاق الترددي الكامل مع قائمة Queue Tree عدم وجود اتصال الحزم لكل عميل ، وخاصة للتعامل مع شبكة الإنترنت مع العديد من العملاء.

المبدأ هو تقسيم النطاق الترددي ( الباندوث ) بالتساوي على جميع العملاء مع عرض النطاق الترددي أكبر من ذلك ينبغي أن يعطى كحد أقصى للنطاق الترددي على كل عملاء ، حيث قمنا بتعيين الألعاب عبر الإنترنت ، والتصفح ، والتنزيل ، وحزم بث الفيديو ، وحزم الاتصال.

حسنًا ، الآن سنشغل Full Bandwidth Management باستخدام قائمة Queue Tree.

لجعل القاعدة المعقدة أكثر سهولة ، سأعمل مع السكربتات بسرعة أكبر.

Condition Starting:
Total Bandwidth : Up to 2 M

I have 8 Clients
Billing : 192.168.1.11
Client1 : 192.168.1.17
Client2 : 192.168.1.16
Client3 : 192.168.1.15
Client4 : 192.168.1.14
Client5 : 192.168.1.20
Client6 : 192.168.1.21
Master : 192.168.1.8

In-Interface : ether1
Out-Interface : wlan1

Address List
/ip firewall address-list
add address=192.168.1.0/24 disabled=no list=MikroTik comment=""

1. فصل وتمييز حزم الاتصال “للخارج والداخل” على Globally

وضع علامة على كل حزمة الاتصال في جهاز التوجيه mikrotik وحركة المرور فيه ، فإنه يعتمد نسبيًا على الواجهة المستخدمة.

حزم الاتصال الخارجة من الواجهة المحلية عبارة عن حزمة اتصال في الواجهة العامة ، يتم تنزيل حزمة الاتصال والخروج من الواجهة المحلية في الواجهة العامة ، ليتم تحميل حزمة الاتصال.

يتم تنفيذ هذا بالسكربت أدناه :

/ip firewall mangle
add action=mark-connection chain=prerouting disabled=no in-interface=ether1 new-connection-mark=All-Inconn passthrough=yes comment="UPSTEAM CONNECTION"
add action=mark-packet chain=prerouting connection-mark=all-inconn disabled=no new-packet-mark=All-inpkt passthrough=yes comment="UPSTEAM"
add action=mark-connection chain=forward disabled=no in-interface=wlan1 new-connection-mark=All-Outconn passthrough=yes comment="DOWNSTEAM CONNECTION"
add action=mark-packet chain=forward connection-mark=all-outconn disabled=no new-packet-mark=All-Outpkt passthrough=yes comment="DOWNSTEAM"
  
/queue tree
add name=All-Bandwidth parent=global-out packet-mark=All-Outpkt queue=default priority=8 max-limit=2M

سوف نركز على All-Outconn كما ترون في البرامج النصية أعلاه ، حزم الاتصال التي تستخدم السلسلة = forward و out-interface = wlan1.

من هذه العلامة ، نحصل على All-Outpkt التي يمكننا فصلها مرة أخرى مع أنواع حزم الاتصال التي نحتاجها.

2. فصل تنزيل حزم الاتصال لكل عميل IP

حزمة التنزيل العامة All-Outpkt ، سنقوم بفصلها في حزم اتصال لكل عنوان IP للعميل ، لالتقاط تنزيل الاتصال الذي يستخدمه العملاء.

يتم تطبيقه على البرامج النصية التالية:

/ip firewall mangle
add action=mark-packet chain=forward dst-address=192.168.1.11 packet-mark=All-Outpkt new-packet-mark=Billing-pkt passthrough=yes comment="BILLING DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.17 packet-mark=All-Outpkt new-packet-mark=Client1-pkt passthrough=yes comment="CLIENT1 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.16 packet-mark=All-Outpkt new-packet-mark=Client2-pkt passthrough=yes comment="CLIENT2 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.15 packet-mark=All-Outpkt new-packet-mark=Client3-pkt passthrough=yes comment="CLIENT3 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.14 packet-mark=All-Outpkt new-packet-mark=Client4-pkt passthrough=yes comment="CLIENT4 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.20 packet-mark=All-Outpkt new-packet-mark=Client5-pkt passthrough=yes comment="CLIENT5 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.21 packet-mark=All-Outpkt new-packet-mark=Client6-pkt passthrough=yes comment="CLIENT6 DOWNSTREAM"
add action=mark-packet chain=forward dst-address=192.168.1.8 packet-mark=All-Outpkt new-packet-mark=Master-pkt passthrough=yes comment="MASTER DOWNSTREAM"
 
  
/queue tree
add name=Billing parent=All-Bandwidth packet-mark=Billing-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=Client1 parent=All-Bandwidth packet-mark=Client1-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=Client2 parent=All-Bandwidth packet-mark=Client2-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=Client3 parent=All-Bandwidth packet-mark=Client3-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=Client4 parent=All-Bandwidth packet-mark=Client4-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=Client5 parent=All-Bandwidth packet-mark=Client5-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=Client6 parent=All-Bandwidth packet-mark=Client6-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name=Master parent=All-Bandwidth packet-mark=Master-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s

 mangle scripts أعلاه مضمنة مع قواعد قائمة Queue Tree.

من هنا قمنا للتو بإنشاء حزم اتصالات التنزيل لكل عملاء ، مثل :

Connection Packets Per Client : Billing-pkt, Client1-pkt, Client1-pkt, Client2-pkt, Client3-pkt, Client4-pkt, Client5-pkt, Client6-pkt, Master-pkt

3. فصل عملاء حزم التنزيل إلى حزم اتصال متنوعة

سيتم تقسيم حزم Connections لكل عميل قمنا به للتو إلى أربع حزم اتصال رقيقة مثل التصفح والألعاب عبر الإنترنت والتنزيل وتدفق الفيديو.

سنقوم بعمل 4 أنواع من حزم الاتصال.

إذا كنت ترغب في إنشاء حزم اتصال أخرى ، فيمكنك التعريف باستخدام بروتوكولات layer 7.

الجزء الأول :-

إنشاء حزم الاتصال لكل عميل من التنزيل وإعداد الأولوية في قواعد شجرة قائمة Queue Tree كما يحلو لك ، يمكنك رؤية السكربتات أدناه :

/ip firewall layer7-protocol
add comment="" name=download regexp="^.*get.+\\.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat|mov).*\$"
  
/ip firewall mangle
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=billing-dpkt passthrough=no packet-mark=Billing-pkt comment=Billing-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client1-dpkt passthrough=no packet-mark=Client1-pkt comment=Client1-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client2-dpkt passthrough=no packet-mark=Client2-pkt comment=Client2-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client3-dpkt passthrough=no packet-mark=Client3-pkt comment=Client3-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client4-dpkt passthrough=no packet-mark=Client4-pkt comment=Client4-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client5-dpkt passthrough=no packet-mark=Client5-pkt comment=Client5-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=client6-dpkt passthrough=no packet-mark=Client6-pkt comment=Client6-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-mark=master-dpkt passthrough=no packet-mark=Master-pkt comment=Master-Down
 
/ip firewall mangle
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=billing-dpkt packet-mark=Billing-pkt protocol=tcp comment="Billing-Down"
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client1-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down"
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client2-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down"
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client3-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down"
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client4-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down"
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client5-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down"
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=client6-dpkt packet-mark=Client1-pkt protocol=tcp comment="Billing-Down"
add action=mark-packet chain=forward connection-bytes=1000000-0 src-port=80,443 passthrough=yes new-packet-mark=master-dpkt packet-mark=Master-pkt protocol=tcp comment="Billing-Down"
   
/queue tree
add name=Billing-Down parent=Billing packet-mark=billing-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client1-Down parent=Client1 packet-mark=client1-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client2-Down parent=Client2 packet-mark=client2-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client3-Down parent=Client3 packet-mark=client3-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client4-Down parent=Client4 packet-mark=client4-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client5-Down parent=Client5 packet-mark=client5-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Client6-Down parent=Client6 packet-mark=client6-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s
add name=Master-Down parent=Master packet-mark=master-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s

استخدمنا هنا حزمة الاتصالات لكل عميل ولعمل حزم اتصال تمديد تنزيل الملف ، لذلك إذا كان هناك أي ملفات ملحق تريد تقييدها ، فما عليك سوى إضافة ملفات الامتدادات الأخرى إلى بروتوكولات layer7 مثل البرامج النصية أعلاه.

الجزء الثاني.

إنشاء حزمة اتصال تدفق الفيديو لكل عميل وقواعد شجرة قائمة Queue Tree التي تعطيها الأولوية كما تريد.

هنا السكربتات التي يمكنك لصقها على نافذة النيوترمنال الجديدة :

/ip firewall layer7-protocol
add comment="" name=streaming regexp="^.*get.+\\.(c.youtube.com|cdn.dailymotion.com|metacafe.
/ip firewall mangle
add comment=Billing-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=billing-spkt passthrough=no packet-mark=Billing-pkt
add comment=Client1-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client1-spkt passthrough=no packet-mark=Client1-pkt
add comment=Client2-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client2-spkt passthrough=no packet-mark=Client2-pkt
add comment=Client3-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client3-spkt passthrough=no packet-mark=Client3-pkt
add comment=Client4-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client4-spkt passthrough=no packet-mark=Client4-pkt
add comment=Client5-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client5-spkt passthrough=no packet-mark=Client5-pkt
add comment=Client6-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client6-spkt passthrough=no packet-mark=Client6-pkt
add comment=Master-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=master-spkt passthrough=no packet-mark=Master-pkt
   
/queue tree
add name=Billing-Streams parent=Billing packet-mark=billing-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client1-Streams parent=Client1 packet-mark=client1-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client2-Streams parent=Client2 packet-mark=client2-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client3-Streams parent=Client3 packet-mark=client3-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client4-Streams parent=Client4 packet-mark=client4-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client5-Streams parent=Client5 packet-mark=client5-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client6-Streams parent=Client6 packet-mark=client6-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Master-Streams parent=Master packet-mark=master-spkt queue=default priority=7 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s

أعتقد أن هذه هي نفس الطريقة لإنشاء حزم الاتصال مثل :

حزم التنزيل التي تستخدم بروتوكولات الطبقة 7 ، والتي تسمح لك بإنشاء المزيد والمزيد من حزمة الاتصال التي تريدها على طول يمكنك فهم لغة regexp

الجزء الثالث:

إنشاء حزم اتصال ألالعاب عبر الإنترنت لكل عميل مع قواعد قائمة Queue Tree وأولوية حزم الاتصال ، فيما يلي البرامج النصية:

/ip firewall mangle
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-10011,14009-14030,18901-18909 comment="Online Game Portal"
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=tcp dst-port=47611,16666,20000,5105,29000,18901-18909,9015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005,27015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=27005-27020,13055,7800-7900,12060-12070
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=8005-8010,9068,1293,1479,9401,9600,30000
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-mark=gpkt passthrough=yes protocol=udp dst-port=14009-14030,42051-42052,40000-40050,13000-13080
  
/ip firewall mangle
add action=mark-packet chain=forward new-packet-mark=billing-gpkt passthrough=no src-address=192.168.1.11 packet-mark=gpkt comment=Billing-Game
add action=mark-packet chain=forward new-packet-mark=client1-gpkt passthrough=no src-address=192.168.1.17 packet-mark=gpkt comment=Client1-Game
add action=mark-packet chain=forward new-packet-mark=client2-gpkt passthrough=no src-address=192.168.1.16 packet-mark=gpkt comment=Client2-Game
add action=mark-packet chain=forward new-packet-mark=client3-gpkt passthrough=no src-address=192.168.1.15 packet-mark=gpkt comment=Client3-Game
add action=mark-packet chain=forward new-packet-mark=client4-gpkt passthrough=no src-address=192.168.1.14 packet-mark=gpkt comment=Client4-Game
add action=mark-packet chain=forward new-packet-mark=client5-gpkt passthrough=no src-address=192.168.1.20 packet-mark=gpkt comment=Client5-Game
add action=mark-packet chain=forward new-packet-mark=client6-gpkt passthrough=no src-address=192.168.1.21 packet-mark=gpkt comment=Client6-Game
add action=mark-packet chain=forward new-packet-mark=master-gpkt passthrough=no src-address=192.168.1.8 packet-mark=gpkt comment=Master-Game
 
/queue tree
add name=Billing-Game parent=Billing packet-mark=billing-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client1-Game parent=Client1 packet-mark=client1-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client2-Game parent=Client2 packet-mark=client2-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client3-Game parent=Client3 packet-mark=client3-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client4-Game parent=Client4 packet-mark=client4-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client5-Game parent=Client5 packet-mark=client5-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Client6-Game parent=Client6 packet-mark=client6-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
add name=Master-Game parent=Master packet-mark=master-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s

في هذه الحالة ، قمنا بإنشاء اتصال للألعاب عبر الإنترنت ، باستخدام منفذ tcp و udp اللعبة اللذين استخدمهما خادم الألعاب عبر الإنترنت.

لذلك يجب عليك منافذ الألعاب عبر الإنترنت التي تستخدم عادة.

هنا أقوم بجمع المنافذ لتكون واحدة قبل أن نتمكن من الفصل بواسطة عنوان IP الخاص بالعملاء الذين لديك.

ثم أخيرًا ، يمكننا التقاط حزم الألعاب عبر الإنترنت في قواعد شجرة قائمة الانتظار للأولوية وإدارة النطاق الترددي لهذا الغرض.

الجزء الرابع.

إنشاء حزم اتصال الاستعراض لكل عميل كاملة مع قواعد قائمة Queue Tree وتمنحك رؤية على البرامج النصية أدناه:

/ip firewall mangle
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Billing-pkt new-packet-mark=billing-bpkt protocol=tcp comment="BILLING BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client1-pkt new-packet-mark=client1-bpkt protocol=tcp comment="CLIENT1 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client2-pkt new-packet-mark=client2-bpkt protocol=tcp comment="CLIENT2 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client3-pkt new-packet-mark=client3-bpkt protocol=tcp comment="CLIENT3 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client4-pkt new-packet-mark=client4-bpkt protocol=tcp comment="CLIENT4 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client5-pkt new-packet-mark=client5-bpkt protocol=tcp comment="CLIENT5 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Client6-pkt new-packet-mark=client6-bpkt protocol=tcp comment="CLIENT6 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-port=80,443 passthrough=no packet-mark=Master-pkt new-packet-mark=master-bpkt protocol=tcp comment="MASTER BROWSING"
  
/queue tree
add name="Billing-Browsing" parent=Billing packet-mark=billing-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name="Client1-Browsing" parent=Client1 packet-mark=client1-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name="Client2-Browsing" parent=Client2 packet-mark=client2-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name="Client3-Browsing" parent=Client3 packet-mark=client3-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name="Client4-Browsing" parent=Client4 packet-mark=client4-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name="Client5-Browsing" parent=Client5 packet-mark=client5-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name="Client6-Browsing" parent=Client6 packet-mark=client6-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s
add name="Master-Browsing" parent=Master packet-mark=master-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s

ما زلنا نستخدم حزم الاتصال لكل عميل لعمل حزم اتصال التصفح.

هنا نستخدم المنفذ 80 و 443 (HTTP و HTTPS) ، ونحدد بايتات الاتصال الصغيرة = 0-1000000 ، التي تستخدم المنافذ التي تستخدم عادة عندما يتصفح العميل أي عنوان url لموقع الويب.

هنا قمنا للتو بتنفيذ “شجرة قائمة انتظار Parent إدارة كاملةللنطاق الترددي” ، ثم يمكنك تخصيص البرامج النصية من خلال واجهة جهاز mikrotik الذي تستخدمه ، وعنوان IP للعملاء الذين لديك ، حتى تتمكن من إدارة قواعد قائمة Queue Tree والنتيجة النهائية.

لمزيد من السرعة تحتاج فقط إلى نسخ جميع النصوص إلى نافذة النيوترنال من winbox.

هذه هي حزم الاتصال التي تنقسم إلى أربع حزم رئيسية من حزم الاتصال مثل :

التنزيل والتصفح وتدفق الفيديو والألعاب عبر الإنترنت)

وسوف تلتقط قواعد قائمة Queue Tree العلامات التي أنشأناها على قواعد mangle وسوف تقوم قائمة Queue Tree بإدارة علامة الحزمة.

 لمزيد من التفاصيل ، يمكنك مشاهدة مقطع الفيديو هذا الذي قمت بتضمينه اعلاه .

أنتهى … إدارة عرض النطاق الترددي الكامل بقائمة Queue Tree في سيرفر المايكروتك

إدارة عرض النطاق الترددي الكامل بقائمة Queue Tree في سيرفر المايكروتك

ملاحظة :

قد تكون المقالة محمية ضد النقل :

وبالتالي لنسخ الاكواد ان وجدت انقر على علامة + بأعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم إدارة عرض النطاق الترددي الكامل بقائمة Queue Tree في سيرفر المايكروتك

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع إدارة عرض النطاق الترددي الكامل بقائمة Queue Tree في سيرفر المايكروتك لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

The post إدارة عرض النطاق الترددي الكامل بقائمة Queue Tree في سيرفر المايكروتك appeared first on حضرموت التقنية.

May 13th 2019, 5:57 am
اقرأ على الموقع الرسمي

0 comments
Write a comment
Get it on Google Play تحميل تطبيق نبأ للآندرويد مجانا