Get it on Google Play تحميل تطبيق نبأ للآندرويد مجانا اقرأ على الموقع الرسمي

الوصول عن بعد لجهاز DVR CCTV Server على Mikrotik من الشبكة المحلية والجوال

حضرموت التقنية

الوصول عن بعد لجهاز DVR CCTV Server على Mikrotik من الشبكة المحلية والجوال

تعلم الشبكة باستخدام Mikrotik مع نظام تشغيل جهاز التوجيه كان ممتعًا للغاية.

في هذه اللحظة :

أود أن أكتب ملاحظة حول كيفية الوصول عن بُعد أو الوصول إلى DVR كخادم كاميرا / CCTV على شبكة Mikrotik الخاصة بنا عن طريق إنشاء قواعد إعادة توجيه المنافذ على جدار الحماية nat لنظام تشغيل جهاز التوجيه Mikrotik.

ربما تكون مثلي تريد أن تكون قادرًا على رؤية مكان معين تشعر أنه مهم للحفاظ عليه آمنًا في ملاحظتك أينما كنت.

لا يبدو أن هذه مشكلة كبيرة ، نظرتك في يديك الآن على هاتفك المحمول.

من الواضح أنه لأسباب أمنية تحتاج إلى نظام مراقبة في المكتب أو حتى في منزلك.

تركيب كاميرا CCTV (تلفزيون الدائرة المغلقة) ليس بالأمر الصعب.

أعتقد الآن أنك تريد شراء الكاميرا على أمل أن تكون قادرًا على رؤية المكان الذي تعتقد أنه قد يكون ضروريًا لك.

ربما لديك CCTV مثبت بالفعل ، لكنك لا تعرف نظام شبكة CCTV.

آمل بعد ذلك أن تتمكن من إدارة شبكة CCTV بنفسك.

لنلقي نظرة على الصورة التخطيطية أدناه!

استنادًا إلى الصورة التخطيطية أعلاه ، لدينا اتصال بالإنترنت مع IP ثابت عام متصل بالمنفذ 1 بواجهة wan mikrotik باسم الإنترنت.

ينتقل الإنترنت إلى جهاز التوجيه والخروج إلى الشبكة عبر المنفذ 4 بواجهة الشبكة المحلية المسماة بـ localnet-3.

بعد ذلك ، سيتم مشاركة اتصال الإنترنت الذي تنكره الموجه بالفعل إلى شبكة المنطقة المحلية باستخدام مفتاح التبديل / لوحة الوصل.

يجب تعيين خادم DVR CCTV كعميل جهاز للشبكة المحلية باستخدام IP ثابت

ويمكن القيام به عن طريق تعيين خادم DVR وحيدا مثلك تعيين IP التكوين على عميل الكمبيوتر الذي يستخدم IP ثابت.

عادةً ما يحتوي خادم DVR CCTV على المنفذ الذي يمكنك ضبطه يدويًا ، أو ترك رقم المنفذ حسب الصنع الافتراضي فقط ، ما عليك سوى معرفة المنفذ الذي استخدم للوصول إلى DVR كخادم CCTV.

كما تعلم :

هناك نوعان من الكاميرات / الدوائر التلفزيونية المغلقة مثل الكاميرا التناظرية التي تستخدم كبل متحد المحور ، مثل نوعه مثل تلفزيون كابل الهوائي الشائع المتصل بـ DVR وكاميرا IP التي تستخدم كبل LAN.

بالتأكيد عند شراء الكاميرات ، يجب أن تعرف نوع DVR كخادم الكاميرا ، وذلك باستخدام كبل متحد المحور أو كبل LAN سيتم توصيله.

في هذا التطبيق كنت تستخدم الكاميرات التناظرية و DVR. سيعمل DVR كخادم الكاميرات لعرض وتسجيل إظهار ما تلتقطه الكاميرا.

في هذه الحالة ، لا أعرض عليك كيفية إعداد DVR كخادم ، وربما أقل من سجلي.

لكن ثق بي أنه من السهل أن يعتمد على ماركة DVR لديك.

إذا كنت ترغب في إعداد DVR ، فيمكنك توصيل الشاشة ، وربما يجب أن تكون شاشة الكمبيوتر متصلاً DVR ، يمكنك توصيل الماوس ولوحة المفاتيح بالكمبيوتر إذا لزم الأمر ، ثم ابدأ في DVR.

سيطلب منك DVR كلمة مرور تسجيل الدخول للوصول إلى قائمة DVR. قد يمكنك العثور على تسجيل الدخول الافتراضي في مطاردة DVR الجسم نفسه. بعد تسجيل الدخول ، تبدأ في إعداد تهيئة DVR ، اعتمادًا حقًا على تكوينك. فقط للإشارة :

IP address (static) : 192.168.3.5
Subnet Mask: 255.255.255.0
Default Gateway (real) : 192.168.3.1
Preferred dns server : 8.8.8.8
Alternate dns server : 8.8.4.4
Media Port : 34567
Mobile Port: 5000

هذه هي النقطة في تكوين DVR ، مرة أخرى حسب اعتمادها على بيئة الشبكة لديك.

قد لا يحتوي بعض DVR أو يوفر لك منفذ وسائط.

في هذه الحالة ، يجب عليك الوصول إلى خادم الكاميرا فقط من منفذ الهاتف المحمول عبر هاتفك المحمول من خلال الإنترنت من خارج شبكتك.

كما الصورة التخطيطية ، دعنا نفترض:

تكوين جهاز التوجيه Mikrotik:

Wan/public Interface : Internet
Public Network : 114.6.112.92/30
Gateway IP : 114.6.112.93
Public IP: 114.6.112.94

Lan/Local Interface : localnet-3
Local Network : 192.168.3.0/24
Gateway IP : 192.168.3.1

مراقبة أمان الكمبيوتر:

IP address (dynamic) : 192.168.3.13
Subnet Mask: 255.255.255.0
Default Gateway (real) : 192.168.3.1
Preferred dns server : 8.8.8.8
Alternate dns server : 8.8.4.4

حسب هذا الشرط ، ماذا تريد أن تفعل؟

1. الوصول إلى خادم DVR CCTV عرض كاميرا عرض من الشبكة المحلية

هدفنا هو الوصول إلى خادم DVR CCTV من خلال الشبكة المحلية في نفس واجهة المنفذ المحلي لجهاز mikrotik router ولا نحتاج إلى إضافة أو إنشاء قواعد جديدة لتكوين mikrotik الذي تم تشغيله.

إذا كان DVR الخاص بك يوفر برنامج Camera Client View ، فيمكنك تثبيت البرنامج على عميل الكمبيوتر الشخصي ، وفي هذه الحالة يكون جهاز مراقبة أمان الكمبيوتر الشخصي.

ولكن إذا لم يوفر DVR أي برنامج ، فقد تحتاج إلى برنامج جهة خارجية مثل CMS2000. أعتقد أنك تماما مثل البرمجيات الحرة!

تقوم بإجراء التكوين للوصول إلى خادم DVR CCTV من الشبكة المحلية في نفس الواجهة أو خادم DHCP لجهاز التوجيه.

قم بإنشاء اسم التكوين وكلمة مرور تسجيل الدخول الخاصة بـ DVR التي قمت بإعدادها مسبقًا ، وأدخل عنوان IP DVR ومنفذ الوسائط المستخدم للوصول إلى خادم DVR.

بعض الناس يستخدمون عادة 34567 | 7000 | 8000 | 9000 كمنفذ وسائط DVR.

مجرد رأيي اترك تكوين المنفذ بشكل افتراضي من أجل عدم دعوة أي مشكلة أثناء الإعداد.

إذا واجهتك مشكلة في الوصول إلى خادم DVR CCTV من الشبكة المحلية ، فمن المحتمل أن يكون سبب ذلك هو عميل الكمبيوتر الشخصي الذي استخدمته في واجهة أو شبكة / شبكة فرعية مختلفة.

عند استخدام واجهة مختلفة مثل هذه ، قد تحتاج إلى إعداد الجسر على جهاز التوجيه ، أو يمكنك فقط الوصول من جهاز توجيه IP العام نفسه.

لذا لتجنب أي مشكلة أثناء التهيئة ، ما عليك سوى وضع مراقبة عميل الكمبيوتر في نفس الواجهة أو شبكة جهاز التوجيه.

شيء آخر قد يكون السبب هو قواعد تصفية جدار الحماية على جهاز التوجيه التي قد تمنع الاتصال.

خادم DVR معطلا يمكن أن يكون سبب المشكلة أيضا ، حاول إعادة تعيين DVR.

الاحتمال الأخير هو DVR هو كسر النظام ، وشراء واحدة جديدة ، لول!

2. الوصول إلى خادم DVR CCTV عرض كاميرا عرض من الإنترنت

سيكون هذا هو الشيء الرئيسي الذي أريد شرحه ، وهو الهدف الرئيسي وهو كيف يمكننا الوصول إلى كاميرا DVR CCTV في كل مكان طالما كان لدينا اتصال بالإنترنت.

هذه هي الطريقة التي يمكننا من خلالها الوصول إلى الكاميرات من خلال IP العام في Mikrotik كموجه للشبكة حيث يوجد DVR CCTV.

لنفترض أن لدينا IP العام الذي لم يتغير أو ثابت 114.6.112.94.

إذا كنت تعرف IP الخاص باتصال الإنترنت الخاص بـ ISP ، فلديك IP عمومي خاص أم لا.

يجب علينا إنشاء وسائل جديدة بورتات إعادة توجيه وبورت المحمول DVR على جدار الحماية نات Mikrotik.

من نفس النوع مثل ما قمت به كمقال بناء خادم استضافة المواقع.

لذلك يجب عليك إنشاء قاعدتين  لكل منفذ DVR مثل أدناه!

/ip firewall nat
add action=dst-nat chain=dstnat comment="CCTV Media Port Fowarding" dst-address=114.6.112.94 dst-port=34567 protocol=tcp to-addresses=192.168.3.5 to-ports=34567
add action=dst-nat chain=dstnat comment="CCTV Mobile Port Fowarding" dst-address=114.6.112.94 dst-port=5000 protocol=tcp to-addresses=192.168.3.5 to-ports=5000

ببساطة أستطيع أن أقول ، نحن نفعل إعادة توجيه منفذ وسائط CCTV إلى منفذ وسائط IP العام سيتم إعادة توجيه إلى منفذ وسائط DVR IP الذي يستخدم بروتوكول TCP فقط.

سيتيح لك ذلك الوصول إلى خادم DVR CCTV عبر IP العام باستخدام الكمبيوتر الشخصي أو الكمبيوتر المحمول مع برنامج عرض عميل الكاميرا مثل CMS2000.

من ناحية أخرى ، نضيف أيضًا قاعدة إعادة توجيه منفذ الهاتف المحمول CCTV ، والتي ستتيح لك الوصول إلى خادم DVR CCTV باستخدام جهاز محمول مع أي تطبيق محمول مثل HDIVS.

HDIVS متاح على نظام التشغيل Android و iOS لهاتفك المحمول.

لقد قمنا بإضافة ميزة إعادة توجيه منفذ القواعد على mikrotik firewall nat ، وبعد ذلك:

نحن على استعداد لتثبيت برنامج عرض عميل الكاميرا على جهاز الكمبيوتر / الكمبيوتر المحمول (CMS2000) وتطبيق عرض عميل الكاميرا على الجهاز المحمول (HDIVS).

تمامًا مثل ما تم إنجازه مثل إعداد خادم الوصول إلى الدوائر التلفزيونية المغلقة DVR عرض طريقة عرض الكاميرات من الشبكة المحلية

لكننا سنستخدم الآن عنوان IP العام في التهيئة كما هو موضح في الصورة أدناه!

الصورة أعلاه هي كيفية تكوين برنامج عرض عميل الكاميرا في هذه الحالة CMS2000 على الكمبيوتر المحمول للوصول إلى الكاميرا من خادم IP DVR العام.

يفترض أن لديك IP عام خاص من موفر خدمة الإنترنت الخاص بك على خادم DVR CCTV.

في معظم الحالات :

ستحتاج إلى الوصول إلى الكاميرا في أي مكان تريده. لهذا النوع من الأغراض ، يتعين عليك إعداد تطبيق عميل الكاميرا على جهازك المحمول الذي لديه اتصال بالإنترنت.

الصورة أدناه هي كيف يمكنك تكوين تطبيق HDIVS على جهازك المحمول!

إذا وجدت أي مشكلة في الوصول إلى خادم DVR CCTV ، يمكنك عرض كاميرا العرض عن بُعد عبر الإنترنت أو IP العام.

حاول عبور التحقق من أن لديك الطريقة الصحيحة في إنشاء وسائط إعادة توجيه منفذ القواعد الجديدة ومنفذ DVR المحمول على جدار الحماية nat Mikrotik حول IP العام لجانب خادم DVR.

تأكد من فتح الوصول إلى الوسائط ومنفذ الهاتف المحمول.

انتقل إلى yougetsignal.com اكتب عنوان IP العام الخاص بك مع الوسائط ومنفذ الهاتف المحمول الذي يجب فتحه

مثل الصورة أدناه!

يستحيل الوصول إلى الكاميرا عن بُعد عبر الإنترنت نظرًا لأنك وجدت أن المنفذ لا يزال مغلقًا.

حاول التحقق من قواعد جدار الحماية وتأكد من عدم وجود قاعدة تحظر الوصول إلى المنفذ.

في معظم الحالات ، حاول إعادة تشغيل خادم كاميرا DVR CCTV.

هذا هو المفهوم كيف يمكننا الوصول إلى خادم كاميرا DVR CCTV من الشبكة المحلية وبعده عبر IP العام.

ربما يتساءل البعض منكم حول ما إذا كان لدينا فقط عنوان IP عام حيوي على خادم الكاميرا.

يمكن حلها عن طريق الوصول من اسم المجال DNS.

يرجى قراءة كيفية الإعداد noIP على مقالة بناء خادم استضافة المواقع عن طريق النفس باستخدام Dynamic IP.

بعد أن يكون لديك اسم مجال على noip.com ويتصل بـ IP الديناميكي العام الخاص بك

يجب عليك تحديثه عن طريق استخدام Script Automatic Update Dynamic IP في جهاز التوجيه مثل البرنامج النصي أدناه!

/system script
add name=no-ip_ddns_update policy=read,write,test source={
 :local noipuser "your_user_login_noIP"
 :local noippass "your_password_login_noIP"
 :local noiphost "yourdomain.ddns.net"
 :local inetinterface "your_wan_interface_router"
 :global previousIP
 :if ([/interface get $inetinterface value-name=running]) do={
  :log info "Fetching current IP"
  /tool fetch url="https://www.trackip.net/ip" mode=http dst-path=mypublicip.txt
  :local currentIP [/file get mypublicip.txt contents]
  :log info "Fetched current IP as $currentIP"
  :for i from=( [:len $currentIP] - 1) to=0 do={
   :if ( [:pick $currentIP $i] = "/") do={
    :set currentIP [:pick $currentIP 0 $i]
   }
  }
  :if ($currentIP != $previousIP) do={
   :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
   :set previousIP $currentIP
   :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
   :local noiphostarray
   :set noiphostarray [:toarray $noiphost]
   :foreach host in=$noiphostarray do={
    :log info "No-IP: Sending update for $host"
    /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
    :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
   }
  }  else={
   :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
  }
 } else={
  :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
 }
}

/system scheduler
add interval=2m name=no-ip_ddns_update on-event=no-ip_ddns_update policy=read,write,test comment="Update No-IP DDNS" disabled=no

باستخدام Script Automatic Update Dynamic IP :

سيعمل جهاز التوجيه على تحديث IP الديناميكي الخاص بك الذي لا يزال مرتبطًا بمجال ddns من أجل الوصول إلى الكاميرا.

في هذه الحالة :

قمنا بتغيير قليلاً من أجل إعادة توجيه منفذ قواعد الخادم DVR CCTV Camera Server الذي لم يعد يستخدم IP عمومي

وإلا يجب الرجوع إلى موجه واجهة الشبكة الواسعة مثل القواعد أدناه!

/ip firewall nat
add action=dst-nat chain=dstnat comment="CCTV Media Port Fowarding" in-interface= your_wan_interface_router dst-port=34567 protocol=tcp to-addresses=192.168.3.5 to-ports=34567
add action=dst-nat chain=dstnat comment="CCTV Mobile Port Fowarding" in-interface= your_wan_interface_router dst-port=5000 protocol=tcp to-addresses=192.168.3.5 to-ports=5000

هذا كله يتعلق بوحدة خدمة DVR CCTV Camera Server على شبكة Mikrotik الخاصة بنا

فقد تحتاج إلى مشاهدة الفيديو بشكل أكثر وضوحًا!

أنتهى … الوصول عن بعد لجهاز DVR CCTV Server على Mikrotik من الشبكة المحلية والجوال

الوصول عن بعد لجهاز DVR CCTV Server على Mikrotik من الشبكة المحلية والجوال

ملاحظة :

قد تكون المقالة محمية ضد النقل :

وبالتالي لنسخ الاكواد ان وجدت انقر على علامة + بأعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم الوصول عن بعد لجهاز DVR CCTV Server على Mikrotik

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع الوصول عن بعد لجهاز DVR CCTV Server على Mikrotik من الشبكة المحلية والجوال لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

The post الوصول عن بعد لجهاز DVR CCTV Server على Mikrotik من الشبكة المحلية والجوال appeared first on حضرموت التقنية.

May 13th 2019, 6:57 am
اقرأ على الموقع الرسمي

0 comments
Write a comment
Get it on Google Play تحميل تطبيق نبأ للآندرويد مجانا